Errors loading Mixpanel.com
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 22, 2019 - 17:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jul 22, 2019 - 12:02 PDT
Identified
We have identified issues loading mixpanel.com and are working to restore service as quickly as possible.
Posted 3 months ago. Jul 22, 2019 - 11:50 PDT
This incident affected: Website.