Mixpanel Services Unavailable
Incident Report for Mixpanel
Resolved
DNS availability has been restored
Posted Oct 21, 2016 - 12:54 PDT
Identified
Mixpanel services are unavailable to some customers due to an ongoing Denial of Service attack on our DNS provider.
Posted Oct 21, 2016 - 09:58 PDT