Report loading delays
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 19:51 PST
Monitoring
An initial fix has been implemented and we are now monitoring.
Posted Nov 15, 2019 - 12:30 PST
Investigating
We're seeing elevated latency on responses from our Query API. This is causing some reports to load slowly and may cause issues with exporting from our APIs. Our engineers are working to fix this issue as quickly as possible.
Posted Nov 15, 2019 - 11:54 PST
This incident affected: Query API.