Issues Sending Email
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 17:50 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2020 - 16:18 PDT
Identified
We are currently working to resolve issues with our email servers. This is impacting project and organization invites sending, password resets, email previews, and email messages. If you have any questions, please contact support: https://mixpanel.com/get-support.
Posted Apr 29, 2020 - 15:36 PDT
This incident affected: Website and Notifications (Mail).