Raw Export API Unavailable
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Nov 27, 2017 - 11:15 PST
Update
We are continuing to monitor this incident and have implemented further changes to improve the reliability of the raw data export API endpoint (https://data.mixpanel.com/api/2.0/export). A handful of customers may still see "export terminated early" returned in the response body of API requests when requesting large amounts of data. We are working hard to eliminate this behavior entirely.
Posted Nov 21, 2017 - 10:31 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 16, 2017 - 11:54 PST
Identified
We've identified an issue causing requests to the raw data export API to timeout or return "export terminated early" in the response body. We are actively implementing a fix.
Posted Nov 16, 2017 - 10:48 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2017 - 16:04 PST
Identified
We have seen an increase in 5xx errors. We're investigating and implementing a fix.
Posted Nov 15, 2017 - 15:41 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2017 - 14:10 PST
Identified
We are seeing requests to the raw data export API respond immediately with the string "export terminated early". We're investigating and working to implement a fix.
Posted Nov 15, 2017 - 13:47 PST
Monitoring
We implemented a fix to resolve raw export API request latency. We are continuing to monitor this incident.
Posted Nov 15, 2017 - 13:01 PST
Identified
We've identified an issue causing requests to the raw data export API to timeout. We are actively implementing a fix.
Posted Nov 15, 2017 - 11:04 PST
Monitoring
We have seen 5xx errors drop off and the API has stabilized. We're continuing to monitor this incident.
Posted Nov 14, 2017 - 15:42 PST
Identified
We have seen an increase in 5xx errors. We're investigating and implementing a fix.
Posted Nov 14, 2017 - 09:55 PST
Monitoring
We have restored service to the raw data export API endpoint and will continue to monitor this incident.
Posted Nov 14, 2017 - 02:28 PST
Investigating
We are aware of 5xx errors re-surfacing. Our engineers are actively working to resolve the issue.
Posted Nov 14, 2017 - 00:54 PST
Monitoring
We have restored service to the raw data export API endpoint and will continue to monitor this incident.
Posted Nov 13, 2017 - 22:57 PST
Update
We are continuing to apply fixes to restore service to the raw data export API endpoint. Service has been partially restored and users may begin to query the API endpoint again.
Posted Nov 13, 2017 - 18:17 PST
Identified
We have identified an issue causing failures on our raw export API (https://data.mixpanel.com/api/2.0/export). Requests to the API endpoint are seeing 5xx error status codes or "export terminated early" in the response body. Our engineering team is actively working to implement a fix and restore service as quickly as possible.
Posted Nov 13, 2017 - 16:26 PST