Reports Impacted
Incident Report for Mixpanel
Resolved
The issue has been fully resolved.
Posted Mar 16, 2017 - 14:52 PDT
Identified
We have confirmed our content delivery network (CDN) momentarily served a corrupted file at one of its locations. If you are impacted by this, the issue can be corrected by hard refreshing your browser. We are still working to correct this issue so no action will be required.
Posted Mar 16, 2017 - 13:44 PDT
Investigating
We are investigating a possible issue of reports failing to load on mixpanel.com

If you have any questions, please contact support@mixpanel.com.
Posted Mar 16, 2017 - 12:57 PDT