Difficulties with loading people reports
Incident Report for Mixpanel
Resolved
All issues with people queries have been solved and all reports are back to normal. Thanks once again for your patience!
Posted Aug 10, 2017 - 06:36 PDT
Investigating
We have identified that some of our customers are receiving errors while loading People reports like Explore. This also affects the creation of new notification campaigns due to the target criteria. We are currently investigating the issue and will update as soon as we have more news. Thanks for your patience.
Posted Aug 10, 2017 - 04:22 PDT