Errors loading Mixpanel.com
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 22, 2019 - 16:34 PDT
Monitoring
Mixpanel.com is now loading successfully and we are continuing to monitor the situation. Thanks for your patience as we worked to resolve this incident.
Posted 4 months ago. Apr 22, 2019 - 13:48 PDT
Identified
We have identified issues loading mixpanel.com and are working to restore service as quickly as possible.
Posted 4 months ago. Apr 22, 2019 - 13:15 PDT
This incident affected: Website.