Temporary Data Ingestion Delay & Ingestion API Errors
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 08:56 PST
Monitoring
Ingestion queues have resolved and real-time functionality is restored. We will continue to monitor and update.
Posted Feb 13, 2020 - 15:11 PST
Update
We are no longer seeing errors for our Track and Engage API endpoints. We are continuing to see an ingestion queue and are working towards reducing the data delay.
Posted Feb 13, 2020 - 13:48 PST
Identified
We are experiencing delays with our data ingestion pipeline. As a result, real-time data is delayed. In order to ensure accurate targeting, messages and new A/B testing experiments have been paused. You can unpause message sending during an ingestion delay in your messages settings. Messages will resume sending once the backlog in the queue has been processed.

We are also seeing elevated errors from the Track and Engage endpoints. Our mobile libraries will automatically retry sending in data and the Javascript library is unaffected.

We appreciate your patience while our engineers work to restore real-time functionality.
Posted Feb 13, 2020 - 12:46 PST
This incident affected: Notifications (Android, iOS, Mail, SMS, Webhook, In-app).