All Systems Operational
Website ? Operational
90 days ago
100.0 % uptime
Today
Query API ? Operational
90 days ago
99.99 % uptime
Today
JavaScript Library CDN ? Operational
Data Collection Operational
90 days ago
100.0 % uptime
Today
Data Export API ? Operational
90 days ago
100.0 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Website Uptime
Fetching
Query API Uptime ?
Fetching
JavaScript Library CDN Uptime
Fetching
Track API Uptime ?
Fetching
People API Uptime ?
Fetching
Export API Uptime ?
Fetching
App Server Uptime ?
Fetching
Import API (service account)
Fetching
Import API (project token)
Fetching
Past Incidents
Mar 29, 2024

No incidents reported today.

Mar 28, 2024

No incidents reported.

Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024
Resolved - This incident has been resolved.
Mar 22, 17:33 PDT
Monitoring - A fix was implemented, and reports should now be loading. We are monitoring the results.
Mar 22, 16:56 PDT
Identified - The issue has been identified, and a fix was implemented.
Mar 22, 16:24 PDT
Investigating - Mixpanel is experiencing degraded Query API performance, causing latency or timeouts when loading data in reports. This is currently affecting US projects.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support

Mar 22, 16:13 PDT
Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024

No incidents reported.