Timestamp offset on a subset of events
Incident Report for Mixpanel
Resolved
An issue affecting timestamps for a subset of events was identified on February 14th. The cause of this bug was a software update on our servers last week that caused the timezone offset of projects to not be applied to events at ingestion. This resulted in some events being stored in UTC time in projects. If your project is in UTC then you will be unaffected.

Our engineering team deployed a fix in two stages: the first on the afternoon of February 14 and the second on the morning of February 16th. This has caused projects to see an anomaly in event volume around 3PM and 4PM PST on February 14th when the first fix went out causing events moving forward to appear with accurate timestamps. There was no data loss and all the events sent to Mixpanel were tracked in your project.
Posted 6 months ago. Feb 21, 2019 - 17:04 PST
Investigating
An issue affecting the timestamp of a subset of events that were being ingested was discovered and our engineers deployed a fix at 3PM PST on Feb 14. This has caused projects to see a decrease in events ingested between 3PM and 4 PM PST on Feb 14. No data has been lost. Our engineers are currently continuing to work on this.
Posted 6 months ago. Feb 15, 2019 - 06:36 PST