Degraded API Performance Impacting Reports for a Subset of Projects
Incident Report for Mixpanel
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 05:33 PDT
Monitoring
Query performance is currently in a good state. We will continue to monitor and post updates.
Posted Mar 17, 2021 - 18:29 PDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 17, 2021 - 18:25 PDT
Update
We're continuing to see degraded query performance. The issues we're seeing are due to being rate limited by an upstream provider and the fix we implemented to reduce the load we're sending them isn't having the impact we expected. We're continuing to work on reducing this load and working with our provider to resolve these issues.
Posted Mar 17, 2021 - 16:56 PDT
Update
We have identified the root cause of this issue and have implemented a fix to restore functionality. It will take some time for the system to recover and will monitor its affects and continue to update here.
Posted Mar 17, 2021 - 14:20 PDT
Identified
A subset of projects are experiencing issues loading reports and exporting data through the API endpoint mixpanel.com/api/2.0/. Our engineers are working to fix this issue as quickly as possible.

We truly appreciate your patience and apologize for the inconvenience. If you have any questions, please contact support@mixpanel.com.
Posted Mar 17, 2021 - 12:31 PDT
This incident affected: Website and Query API.